Instalar Guitar Pro 6 Ubuntu 13.10 64bits

Hace unos días que he intentado instalar la última versión de Guitar Pro 6 para Linux. Lo primero que me molestó fue que no hay ningún paquete de 64 arquitecturas. Sí, has leído bien, es de 2013 y Arobas Música todavía piensa que es aceptable para proporcionar software de 32 bits.

Traté de instalar el paquete de todos modos, confío en que Ubuntu pueda hacer un buen trabajo al instalar las dependencias de bibliotecas de 32 bits requeridos. Desafortunadamente Guitar Pro 6 necesita Gksu entre las dependencias, y no se pueden instalar junto con la versión de 64 bits que ya están en el sistema. Si has leido muy bien, es 2013 y Arobas Music todavía piensa que es aceptable proporcionar software de 32 bits.

Googleando en busca de hallar si alguien había podido resolver este problema, me encontré con un script en los foros de Ubuntu que actualiza el archivo de control en el paquete para eliminar la dependencia incumplidas o erroneas.

Tras la instalación del nuevo paquete , En Lintian me advierte de que el paquete es de mala calidad calidad .

guitar_pro_6_mala_calidad

Yo podría haber corregido el nombre del paquete con el script anterior, pero más controles realizados a encontrar algo aún peor: dos archivos de control OSX ( _.DS_Store y DS_Store . . ) Que se habrían instalado en el directorio raíz !

Decidí entonces dejar de lado el script y hacerlo manualmente:

dpkg-deb -x gp6-full-linux-r11553.deb gp6-tmp
dpkg-deb --control gp6-full-linux-r11553.deb gp6-tmp/DEBIAN
vi gp6-tmp/control # rename GuitarPro6 to guitarpro6, remove gksu dependency
rm gp6-tmp/.DS_Store gp6-tmp/._.DS_Store
dpkg -b gp6-tmp gp6-full-linux-r11553-tastethedifference.deb

Finalmente tuve un paquete que era de buena calidad, así que fue capaz de instalar, ejecutar y registrar el software. Luego, por supuesto, lo siguiente que hice fue correr el actualizador. La actualización fue muy bien, e inicié nuevamente el instalador sólo para descubrir que algo salió mal:

guitar_pro_6

./GuitarPro: /opt/GuitarPro6/./libz.so.1: version `ZLIB_1.2.3.3' not found (required by /usr/lib/i386-linux-gnu/libxml2.so.2)

Esto fue fácil de solucionar renombrando libz.so.1 a libz.so.1.orig, pero luego en la próxima ejecución que se detuvo con una ventana transparente en blanco y se estrelló después de unos segundos:

QGtkStyle was unable to detect the current GTK+ theme.
Segmentation fault (core dumped)

Gracias al blog post en Fedora forums, fuí capaz de identificar el paquete para instalar y solucionar este problema mediante la ejecución definitiva:

sudo apt-get install gtk2-engines:i386

guitar_pro_6_full

No me malinterpreten: Estoy muy agradecido a Arobas Música para proporcionar una compilación de Linux de su software. Lo que me molesta es que con muy poco esfuerzo se podría mejorar mucho la experiencia del usuario.

*******************************

recalcar que primero se debe de instalar el getlib como la instalacion anterior y asi si funciona todo muy bien…

recalcar que primero se debe de instalar el getlib como la instalacion anterior y asi si funciona todo muy bien..

Como Instalar GuitarPro6 en UBUNTU 12.10 64bits

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s